Message
You will see one of the following messages:
- "It seems there’s a balance on your account. To watch this program, please visit My Account to make a payment."
- "We need some help with your account. To watch this program, please visit My Account."
Cause
Account not in good standing (Account on credit hold, customer has requested no charges on this device, etc.) (500-102)
Locker 403-2001
Cause code
You have an outstanding balance on your account preventing you from completing your transaction in the Xfinity Stream app.
Solution code
Confirm that you have no outstanding payments on your account and try again. If the issue persists, please contact us.
Additional information
Visit our Online Support Center to find common solutions.

The easiest way to activate, manage, and troubleshoot your Xfinity experience is with the Xfinity app! Get 24/7 real-time support, pay your bill, view plan details, get outage updates, and more. Download the free Xfinity app, or scan the QR code with your smartphone.
Need additional support? Ask Xfinity Assistant.