Message
"Sorry, we're having some trouble. This program is not available to watch at the moment. Please try again in a few minutes."
Cause
Locker Error (Can't complete the transaction using Locker service) (500-106).
Locker: Any other unhandled error, or communication issue.
Cause code
This transaction is not currently available.
Solution code
Please try again later. If the issue persists, please contact us.
Additional information
Visit our Online Support Center to find common solutions.

The easiest way to activate, manage, and troubleshoot your Xfinity experience is with the Xfinity app! Get 24/7 real-time support, pay your bill, view plan details, get outage updates, and more. Download the free Xfinity app, or scan the QR code with your smartphone.
Need additional support? Ask Xfinity Assistant.