Message
You will see one of the following messages:
- "You've purchased this already!"
- "You've rented this already!"
Cause
Asset is already purchased (500-103) Locker 409-1007
Cause code
You have attempted to purchase content in the Xfinity Stream app that you have already purchased or rented.
Solution code
To access previous purchases, please visit Saved > Purchases in the Xfinity Stream app. To access rentals, please visit For You, and scroll down to the Rented row.
Note: Only rentals that are not expired will appear here.
If the issue persists, please contact us.
Additional information
Visit our Online Support Center to find common solutions.

The easiest way to activate, manage, and troubleshoot your Xfinity experience is with the Xfinity app! Get 24/7 real-time support, pay your bill, view plan details, get outage updates, and more. Download the free Xfinity app, or scan the QR code with your smartphone.
Need additional support? Ask Xfinity Assistant.