Browsers Supported by XFINITY Connect

Print
Find out if XFINITY Connect supports your browser.

If your email looks like the below, proceed to the Supported Browsers - New Experience section.
XFINITY Connect New Experience

If your email looks like the below, proceed to the Supported Browsers section.
XFINITY Connect Old Experience

Supported Browsers - New Experience

XFINITY Connect (New Experience) officially supports the following browsers:

Desktop Browser (Minimum display resolution: 1024 x 768)
For PC:
  • Internet Explorer 11** (latest and previous versions)*
  • Microsoft Edge
  • Firefox (latest and previous version)*
  • Chrome (latest and previous version)*

For Mac:
  • Firefox (latest and previous version)*
  • Safari (latest and previous version)* (Mac OS X only)

*Click on the links below to download the latest versions: **Why can't I see my emails using Internet Explorer 11?
If you are using the latest version of Internet Explorer 11 and you are getting an error about using an out of date browser, please turn off Compatibility View.

To turn off Compatibility View:
  1. Access the Tools menu, and then click Compatibility View settings
  2. Remove xfinity.com and/or comcast.net from the list of websites added
  3. Uncheck use Microsoft compatibility lists
     
Mobile Device Support
Mobile Device Supported Browser Minimum Speed
iPhone on iOS 9 / iOS 10 Safari 3G connections
Smartphone on Android 4.1 or later Chrome (latest and previous version varies by device) 3G connections

Tablet Support
Tablet Supported Browser Minimum Speed
Apple iPad (all devices) on iOS 9 / iOS 10 Safari 3G connections
Tablets on Android 4.1 or later Chrome (latest and previous version varies by device) 3G connections


Back to Top

Supported Browsers

XFINITY Connect officially supports the following browsers:

For PC
  • Internet Explorer 8 or higher
  • Firefox 26 or higher
  • Chrome 31 or higher

For Mac
  • Firefox 26 or higher
  • Safari 6.1 or higher (with Mountain Lion OS)
     
For optimal performance we recommend these browsers:
  • Firefox 3.5 or higher
  • Internet Explorer 8 or higher
  • Safari 3 or higher

Other browsers, such as Opera, may work with XFINITY Connect (Full or Lite versions); however, we don't officially support these browsers.

The Lite version of XFINITY Connect provides support for older operating systems and browsers but it may not provide all of the same functionality as the Full version.

Want to know more? For a comparison, read about the differences between XFINITY Connect and XFINITY Connect Lite.

Back to Top
Print

Find this article at:

https://www.xfinity.com/support/internet/xfinity-connect-supported-browsers/

Was This Article Helpful?

Rate this article on a scale of 1 - 5

Related Articles

Need more help? We're on it.

Find an XFINITY Store or service center near you.